Can't buy "CHF.EUR" on IB

Hi,

I’ve been trying over a week to buy CHF.EUR on IB, but it doesn’t work.

As a matter of fact, when I type “CHF.EUR” in the “Symbol Look Up” field, the link to the Forex appear underneath the field, but nothing happens when I click on it.

What’s strange is that I can buy many other currencies (USD.CHF, EUR.USD, etc.), but CHF.EUR is the only one that doesn’t work.

I tried with Chrome, Firefox, Safari and deactivated AdBlock, but still, nothing helps.

Have you ever had this bug before?

Thanks,

Do you want to exchange CHF to EUR? In this case you should be selling this pair, not buying.

Sorry, I didn’t express myself correctly.

I’d like to buy CHF with Euros (I’ve got some Euros in cash that I’d like to exchange to Swiss francs).

No matter the cash you have in your account, something should happen when you click on the result provided in the “Symbol Look Up” field. If I type EUR.CHF (acquire Euros with Swiss francs), IB takes me to the page where I can trade, but if I type CHF.EUR, nothing’s happening.

Use EUR.CHF as a selling order.

Thank you, it worked!

1 Like

FYI, in general pairs have a canonical order, due to CHF being towards the bottom, most of the time CHF will be expressed as XXX.CHF.

(https://en.wikipedia.org/wiki/Currency_pair has the priority ranking)

I think there are trades in non canonical pairs, but I’d suggest always using the canonical pair to avoid surprises.

I mean it’s the logical thing to do anyway. You have 1000€ and you want CHF. No point in buying CHF when you want to sell exactly 1000€, otherwise you end up with a rest.

2 Likes
By reading and partipating to this forum, you confirm you have read and agree with the disclaimer presented on http://www.mustachianpost.com/
En lisant et participant à ce forum, vous confirmez avoir lu et être d'accord avec l'avis de dégagement de responsabilité présenté sur http://www.mustachianpost.com/fr/